super build simpleitk python wrapping link error

hi all,
I have managed to super build simplitk for java, csharp I guess!? but when it gets to swig python wrapping code generation at linking time I get link error because super build has discovered a python37.lib x86 library in following path>
c:/users/sohrab/appdata/programs/python/python37-32/libs/python37.lib
I am sure that this is a x86 library, I build debug, x64 in vs2019 which I am sure causing this problem.
I initially had installed several years ago anaconda3 which was a big chance of 20G and I then discovered I have three other libraries which are suitable for super build but they are not discovered by super build simpleitk, I did only build python part with adding dependencies : _tkinter.lib, python3.lib, python37.lib I could resolve those link errors for python wrapping.
yesterday I did uninstall anaconda3 and I had already my miniconda3 installed , I assumed this will remove the python37.lib/x86 as well so super build simpleitk won’t pickup that as link path for python libraries in wrapping python, but then I found out I got the same link errors!?
is there any way I can force super build to pick these libraries with some -D flag in super build to resolve this issue?

or any suggestion why after anaconda3 is uninstalled still I see this library getting pickup for linking?

what to do?
good new is that now I have java/csharp wrapping there but python wrapping still not working!

thanks in advance
sag

If there is no option to uninstall that instance of python, just deleting its folder from disk should do the trick.

The easiest way would be to use the CMake GUI to inspect and correct the PYTHON related variables: PYTHON _EXECUTABLE PYTHON _INCLUDE_DIR PYTHON _LIBRARY

Alternatively, you could use ( or look at the configuration of the ) the SimpleITK Conda build recipe: https://github.com/SimpleITK/SimpleITKCondaRecipe

1 Like

Thank you for your attention I finally got it to work!

Regards,
sag

hi @dzenanz,

I Firstly appreciate your attention to this matter and yes I got it to worked for everything like I announced on the forum site.

Regards,
sag