RUNPATH ignored by linker for ITK-libs of newer ITK (4.12.2)

It seems programs compiled (cmake, make, gcc-6.3, debian-9) with newer ITK (e.g. 4.12.2) set the RUNPATH in an executable (with CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE) whereas compiling the same code with older ITK (e.g. 4.9.1) sets the RPATH.
This subtle difference seems to lead to the problem, that I get “error while loading shared libraries” when executing the installed program, even though readelf -d /opt/ITK-CLIs/bin/hist | egrep 'RUNPATH|RPATH' lists the correct RUNPATH. Starting the executable with LD_LIBRARY_PATH set to this RUNPATH lets the linker find the itk-libs, which makes me wonder whether the linker on my current system ignores the RUNPATH.
What can I do about that despite setting LD_LIBRARY_PATH?
How can I make the linker use RUNPATH or how can I compile with itk-4.12.2 such that RPATH is used instead?

Configuring/compiling with SET(CMAKE_EXE_LINKER_FLAGS "-Wl,--disable-new-dtags") makes programs linking to itk-4.12.2 use RPATH instead of RUNPATH. Running the installed executables then does not need LD_LIBRARY_PATH.
What is the best practice to deal with this RUNPATH problem?