Hi,
The current implementation of this function (the constant version) is as follows:
“return ConstIterator( this->VectorType::size() - 1, this->VectorType::end() );”
But should this not be
“return ConstIterator( this->VectorType::size(), this->VectorType::end() );”
As the end iterator is one past the last element in the container?
The same is true for the non-constant version.
Kind regards,
Johannes