'nullptr' error in ITK compiling

Hi all,
When I compiled ITK-4.13.3, I met a lot of "nullptr’ errors if I enable Module_ITKVtkGlue in cmake. The VTK version and gcc version I used is 8.2.0 and 4.8.5. It seems I missed something. Does anybody know the solution? Thanks in advance.

Hi @zhuangming.shen,

You need to compile with at least C++11 capabilities to use nullptr. You can pass the option CMAKE_CXX_STANDARD=11 to your CMake configuration. For details, search compile with C++11 std cmake (for example).

1 Like