NSIS_EXECUTABLE-NOT FOUND


(Hajar Moradmand) #1

Hi,
I am a beginner to ITK, now I am installing ITK(4.13) in Windows 10 and also 7. I did exactly the same as mentioned in the ITK manual instruction. The configuration was done and ITK was generated.
But I faced some notifications in CMake user interface as follow:

MEMORYCHECK_COMMAND-NOT FOUND
NSIS_EXECUTABLE-NOT FOUND
WIX_EXECUTABLE-NOT FOUND
Could anyone help me to find out why this has happened, and how I can fix it, please?
Thanks a lot.


(Pablo Hernandez-Cerdan) #2

Hi @h_moradmand and welcome!

If cmake configuration and generation was done successfully you are all set for building ITK.

Don’t worry about those NOT_FOUND notifications in optional and extra features meant for maintainers and developers.


(Hajar Moradmand) #3

Thank you for reply.
I’m trying to run the “HelloWorld” which I found on the
ITk/Source/example/installation after I build ITK.
I use Cmake GUI and once I try to configure it, I get this error on the
display:

ITK_DIR-NOTFOUND.
CMake Error at CMakeLists.txt:12 (find_package):
** By not providing “FindITK.cmake” in CMAKE_MODULE_PATH this project has**
** asked CMake to find a package configuration file provided by “ITK”, but**
** CMake did not find one.**

** Could not find a package configuration file provided by “ITK” with any of**
** the following names:**

** ITKConfig.cmake**
** itk-config.cmake**

** Add the installation prefix of “ITK” to CMAKE_PREFIX_PATH or set “ITK_DIR”**
** to a directory containing one of the above files. If “ITK” provides a**
** separate development package or SDK, be sure it has been installed.**

What is wrong here?
can you suggest me how to fix it?
I am using windows 10.
Many thanks for considering my request.


(Pablo Hernandez-Cerdan) #4

That’s fine, cmake cannot know where you installed or built ITK. Follow the cmake instructions and using the cmake gui populate the variable ITK_DIR with the path to the folder where you built ITK (build folder, not the source tree).


(Hajar Moradmand) #5

Thank you! It was helpful.


(Hongliang Zu) #6

hi,I also faced the problem when I run the “Hello World”.
problem : CMake Error at CMakeLists.txt:12 (find_package):
Have you solved the problem now?
If you do ,please give me some suggestions.
thanks a lot.


(Pablo Hernandez-Cerdan) #7

Hey @hongliang-zu, same suggestion, try to populate ITK_DIR.


(Hongliang Zu) #8

Thank you very much. It was helpful.
I’m close to solving the problem.
But when I run the “hello world” in vs2013, which show me
“Could not start this program because ITKCommon-4.13.dll was lost on the computer. Try reinstalling the program to resolve this problem”.
Do I need to reinstall ITK?(I didn’t find itkcommon-4.13.dll online)
Could you give me some suggestions?


(Pablo Hernandez-Cerdan) #9

Yeah, it seems like you should build or re-install ITK.


(Dženan Zukić) #10

You don’t have to rebuild or reinstall. You need to add ITK’s bin folder to the path. Alternatively, you could build ITK as static libraries by setting BUILD_SHARED_LIBS to OFF.