No such module: "MinimalPathExtraction"

– Configuring extension directory: TubeTK
– Checking EXTENSION_NAME variable
– Checking EXTENSION_NAME variable - TubeTK
– Configuring Launcher script
– Configuring Launcher script - ok [windows]
– Configuring SEM CLI module: CompareImages
– Configuring executable: CompareTextFiles
– ITKModules: Adding ‘TubeTKITK’ directory
CMake Deprecation Warning at D:/W8/S/S-bld/TubeTK/ITKModules/TubeTKITK/CMakeLists.txt:1 (cmake_minimum_requ
Compatibility with CMake < 2.8.12 will be removed from a future version of

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.

-- Found Python3: D:/W8/S/S-bld/python-install/bin/PythonSlicer.exe (found version "3.6.7") found component

s: Interpreter
CMake Error at D:/W8/S/S-bld/ITK/CMake/ITKModuleAPI.cmake:78 (message):
No such module: “MinimalPathExtraction”
Call Stack (most recent call first):
D:/W8/S/S-bld/ITK/CMake/ITKModuleAPI.cmake:7 (itk_module_load)
D:/W8/S/S-bld/ITK/CMake/ITKModuleAPI.cmake:153 (_itk_module_use_recurse)
D:/W8/S/S-bld/ITK/CMake/ITKModuleMacros.cmake:158 (itk_module_use)
D:/W8/S/S-bld/ITK/CMake/ITKModuleExternal.cmake:161 (itk_module_impl)
D:/W8/S/S-bld/TubeTK/ITKModules/TubeTKITK/CMakeLists.txt:9 (include)

I got a Cmake error in ITK.

I am using the module “MinimalPathExtraction”.

Please help me to solve the above error.

Is the above output result of configuring TubeTK or configuring ITK? What version(s) are you using, and what non-default parameters are you using?

itk-module.txt (835 Bytes)
It’s the output result of configuring TubeTK. I am using ITK version 3.19.7 . TubeTK latest version files.

@Mahesh_Timmanagoudar ITK 3.19.7 does not exist as a release:

The closest versions are 3.18.0 (April 15th, 2010) and 3.20.0 (July 12th, 2010). So +11 years old. It is very unlikely that the latest TubeTK works with releases that date back to those days. Your CMake version (2.8.12) is also very old (October 8th, 2013):

Modern ITK (and probably TubeTK) requires CMake 3.16.3 or newer:

So it is highly likely that an effort to update to more recent versions of the tools (probably including your compiler) will be required to try to solve the problem.

@Mahesh_Timmanagoudar you probably meant CMake 3.19.7, as ITK 3.19.7 doesn’t exist.

If you first configured and compiled ITK, and now trying to configure TubeTK by pointing it to ITK, you should re-configure ITK by enabling Module_MinimalPathExtraction then compiling again. Otherwise I don’t know what’s wrong.

Using the latest master or latest stable release ITK 5.2.1 might help too.

CMakeLists.txt (30.5 KB)
Thanks for correcting me. Yes I first configured ITK and trying TubeTK by pointing to ITK.

I have attached my CMakeList.txt file of ITK. Hope ITK is configured with Module_MinimalPathExtraction.

I have also enabled the flag of ITKV4_COMPATIBILITY also in CMakeList.txt file to overcome the backward compatibility issue.

Please let me know if anything is wrong.

The more relevant file to share is ITK’s CMakeCache.txt in the build directory. Probable path D:/W8/S/S-bld/ITK-build/CMakeCache.txt.

I have attached CMakeCache.txt file of ITK-build directory.
CMakeCache.txt (184.7 KB)

Please let me know if anything required.

As I suspected, the module was disabled during configure: Module_MinimalPathExtraction:BOOL=OFF. Turn it on using CMake GUI, reconfigure, generate, open solution and build it using Visual Studio. Then your TubeTK configure should work.