link error. ld: library not found for -lITKVideoIO

I’m new here for ITK. And I have tried to install ITK-5.2.0
My environment version is as follows : OS:macOS 10.15.6. CMake 3.17.3 Make 3.81 clang 6.0.0
I try to compile and install ITK as the guidebook (ItkSoftwareGuide.pdf) said.
and I wrote a program (hello world) like this

#include "itkImage.h"
#include <iostream>
int main(){
    using ImageType = itk::Image<unsigned short , 3>;
    ImageType::Pointer image = ImageType::New();
    std::cout << "Hello" << std::end;
    return EXIT_SUCCESS;

and the CMakeLists.txt like this

cmake_minimum_required(VERSION 3.17)
find_package(ITK REQUIRED)
add_executable(HelloWorld HelloWorld.cxx)
target_link_libraries(HelloWorld ${ITK_LIBRARIES})

it’s ok when I run “CMAKE”,but when run “MAKE” , I get an error “ld: library not found for -lITKVideoIO”
I thought it may be that I didn’t compile ITK_Module_VideoIO , so I just run

cmake … -DModule_VideoIO:BOOL=ON

it runs successfully. But the error still appears.
I want to know how to fix it.

By the way, when I configure ITK(with terminal ccmake) , there is nothing about ITKGroup_GroupName. I have set ITK_BUILD_DEFAULT__MODULES=OFF and toggle to advanced mode, but nothing changes.

It should be ITK_BUILD_DEFAULT_MODULES, with one underscore (_).

But the main problem seems to be that your ITK did not compile properly. After configuring it, you also need to compile it (run make or ninja step).