Issues passing -DModule_* flags to ccmake.


My build of ITK requires a number of remote modules to be turned on. In order to document and reproduce my build (for collaborators, as well as for my future self) I’ve been writing bash scripts which pass the relevant flags to ccmake during the initial configuration. In doing so, I’ve run into two issues.

  1. Module_SubdivisionQuadEdgeMesh does not turn on when I pass -DModule_SubdivisionQuadEdgeMesh=ON to ccmake.
  2. Module_IOSTL and Module_DVMeshNoise turn on (they download and build), but disappear from the configuration so that they cannot be turned off.
  3. I can then turn on Module_SubdivisionQuadEdgeMesh manually in the curses gui, but it then disappears from the configuration.

I’m not very concerned about points 2 and 3–perhaps this is intended behavior once the modules are downloaded. However, I think that point 1 might be a bug. Has anyone run into this?

Best, and thanks,


Steps to reproduce (on Ubuntu 16.04, cmake 3.10.20180117-gb1fd31, on the master branch, starting with a clean build):

mkdir ITK
cd ITK
git clone src
mkdir bin
cd bin/
ccmake ../src -DModule_SubdivisionQuadEdgeMesh=ON -DModule_IOSTL=ON -DModule_DVMeshNoise=ON
1 Like

Hi Davis,

If you press the t key to show the advanced options in the ccmake GUI, do you see the flags?

Best regards,


Showing the advanced options is necessary to see the Module_* options, of course, but Module_DVMeshNoise is absent. Moreover, Module_SubdivisionQuadEdgeMesh is present but OFF. I can reproduce this issue on Ubuntu 16.04, and a collaborator has also experienced this issue on OsX.