GCC 8.2


(Bill Lorensen) #1

Since my Ubuntu 14.0 does not provide a fully c++11 compiler, I decided to build my own gcc compiler. To protect me from having to go through his again in the future, I have built gcc 8.2.0.

ITK does not build with this version. Here are the first errors

https://open.cdash.org/viewBuildError.php?buildid=5754102


(Pablo Hernandez-Cerdan) #2

Hi @bill.lorensen, I haven’t compiled the wiki examples, but the library and all the tests compile with gcc 8.2.1 in my machine.

Have you compiled all the dependencies (VTK for example) with the new compiler as well?

As a note, I think it is easier to update Ubuntu to 18.04 (or go with a rolling distro) than to install your local gcc.


(Pablo Hernandez-Cerdan) #3

Oh, you are right, I updated ITK to the tip of master and I am hitting your first error too from current master:

Building C object Modules/ThirdParty/HDF5/src/itkhdf5/src/CMakeFiles/hdf5-shared.dir/__/shared/H5Tinit.c.o
FAILED: Modules/ThirdParty/HDF5/src/itkhdf5/src/CMakeFiles/hdf5-shared.dir/__/shared/H5Tinit.c.o
/usr/lib/colorgcc/bin/cc -DH5_BUILT_AS_DYNAMIC_LIB -DH5_BUILT_AS_DYNAMIC_LIB=1 -DNDEBUG -D_GNU_SOURCE -Dhdf5_shared_EXPORTS -IModules/ThirdParty/ZLIB/src -IModules/ThirdParty/ZLIB/src -IModules/ThirdParty/HDF5/src -IModules/ThirdParty/HDF5/src -IModules/ThirdParty/HDF5/src/itkhdf5/src -IModules/ThirdParty/HDF5/src/itkhdf5 -Wno-uninitialized -Wno-unused-parameter -Wall -Wcast-align -Wdisabled-optimization -Wextra -Wformat=2 -Winvalid-pch -Wno-format-nonliteral -Wpointer-arith -Wshadow -Wunused -Wwrite-strings -funit-at-a-time -Wno-strict-overflow  -w -std=c99 -fstdarg-opt -pedantic -Wall -Wextra -fmessage-length=0 -O2 -g -DNDEBUG -fPIC -MD -MT Modules/ThirdParty/HDF5/src/itkhdf5/src/CMakeFiles/hdf5-shared.dir/__/shared/H5Tinit.c.o -MF Modules/ThirdParty/HDF5/src/itkhdf5/src/CMakeFiles/hdf5-shared.dir/__/shared/H5Tinit.c.o.d -o Modules/ThirdParty/HDF5/src/itkhdf5/src/CMakeFiles/hdf5-shared.dir/__/shared/H5Tinit.c.o   -c Modules/ThirdParty/HDF5/src/itkhdf5/shared/H5Tinit.c
In file included from Modules/ThirdParty/HDF5/src/itkhdf5/shared/H5Tinit.c:82:
Modules/ThirdParty/HDF5/src/itkhdf5/src/H5Tpkg.h:23:2: error: #error "Do not include this file outside the H5T package!"
 #error "Do not include this file outside the H5T package!"
  ^~~~~

(Bill Lorensen) #4

Great. I’m glad I’m not the only one…


(Pablo Hernandez-Cerdan) #5

Issue opened: https://github.com/InsightSoftwareConsortium/ITK/issues/509