This patch fixes an unrelated bug in that class.
Maybe a more specific name should be used if it is added to the ITK namespace.
Perhaps add it to
itk::Testing:: namespace? The file location is already suggestive of that.
There is already a SimpleFilterWatcher. Perhaps one of them is redundant? I will look into it later.
There is also itkXMLFilterWatcher.h which derives from
FilterWatcher in Testing dir should at least derive from
SimpleFilterWatcher, if it needs to exist at all. Adding to a TODO list. If someone else wants to take over, just write here.
I just submitted a patch to reduce duplication.