Cleaning up the dashboard

I reported the dynamic analysis reporting failure on CDash’s GitHub here.

We can use this topic for other dashboard-related discussion.

Yes! The dashboard does need some attention!

I address a couple of the hidden Valgrind failure here and here. They were both timeout related. The remaining one, the itkDiscreteHessianGaussianImageFunctionTest, is also timing out. What is off is that in my CTest script I am setting CTEST_TEST_TIMEOUT to 5000, but when the tests are being run (and in the cache) it appears as 1200. I found the following in ITK:

I wonder if the “DART” value is clobbering the CTEST value?
This change could be the reason these timeout have recently started to show.

The dashboard looks a lot better to day! Thanks to all those who contributed :clap: :clap:

So when is the next RC?

Today :slight_smile: I want to have a look at why the Python wrapping only works on
Linux first though…

Ideally, we want to merge this before tagging too.

These patches to solve the valgrind defect notifications whose source was a mystery for a long time are definitely awesome !

As for the itkDiscreteHessianGaussianImageFunctionTest, I’ve tried the gerrit patch:
locally from a fresh master and now it turns out that the 220 s threshold that I chose after some trial and error does not hold at every attempt.

I’ve tried several times with other timeouts (250, 500) and the test passes consistently reporting an execution time of around 213 s. So less than 220 s…

So I’m not sure whether Brad is correct: that the DART_TESTING_TIMEOUT flag reducing the timeouts from 1500 to 1200 by Modules/ThirdParty/HDF5/src/itkhdf5/CMakeLists.txt may be affecting this.

But neither am I sure about why being 213 less than 220 the latter seems no longer to be valid.

The only solution I can think of is printing the variable in CMake with a message to ensure that the variable is changing the timeout for this or other tests, and setting the timer in HDF5 to 1500 and running valgrind on some Linux box anyone may have to see whether that causes the issue.

My environment:
Win 7 64 bit; 2.93 GHz; 16 GB RAM; MSVC 2010